CET Designer 5.0

Last modified: Nov 04, 2015
More about Release Notes

Update – Patch # 5 (September 5, 2014)

Reset / clear Custom Tools when the main Extension is changed (only relevant for our Kitchen users).
Fix for a quick property crash that could occur when an item did not have any quick properties at all.
Remove wireframe and contour rendering options in 3D viewports for the 64-bit version of CET Designer.
Now the “Connect” setting will be remembered for all position tools.

 

Update – Patch #4 (July 30, 2014)

Fix for a 3D graphics bug where some surfaces got an incorrect shape.
The “Show detailed information” checkbox in Print Reports / Article Views will now work as intended.

 

Update – Patch #3 (June 24, 2014)

Fix for an issue where favorites were imported as large blocks.
The Try to connect checkbox setting (in the animation properties of the Position tools) will now be saved.
Fix for the issue that caused CAD plans not to render in Photo Lab.
Fix for copy/paste text issues.
User will now be reminded to save if starting to work in a drawing backup without saving.
Fix for issue with Autosave button.
Fixed issue with bug reports sending backup files instead of the actual drawing file.
Updated the offline help file.
Various elevation fixes.
Various crash fixes.

 

Update – Patch #2 (June 12, 2014)

Fix for an issue that could cause problems with long file paths when applying future updates.

 

Update – Patch #1 (June 2, 2014)

Fixes

Fix for a crash that occurred in Custom Tools if Extensions, with their tabs included in that toolbox, were uninstalled.
Fix for an issue with old ghosts in Photo Lab.
Image resizing is now much faster.
Fix for Calculation settings.
Fix for issues with copy/paste.
The bound of the removal tool will now be updated in a correct way.
Fix for an issue where the tag name was not readable on a dark background.
Fix for a crash in visibility settings in Paper View.
Elevation views fixes.
Fix for a crash that occurred when showing 2D .dwg lines in 3D.
Update to the auto-rollback functionality; CET Designer will no longer be restarted after a folder with damaged Extensions has been deleted.
Added a missing resource.

 


 
[open a printable version]
 

News and Changes in CET Designer 5.0 – May 2014

New Features

Launching the New 3D PDF Extension

Wouldn’t it be great if you could generate PDF files that show your complete 3D view and let your clients turn around and zoom in and out of your drawing to see every detail – without using CET Designer?

Our brand new 3D PDF Extension lets you save your drawings and send them to your clients as 3D PDF files that can be opened and viewed in Acrobat Reader version 8 or later; one of the most common, free PDF viewers available.

The 3D PDF Extension is available for purchase in our Marketplace.

So, how do you generate dynamic 3D PDF files from CET Designer? There are three ways to generate a 3D PDF file:

  • On the 3D PDF component tab, click the Export active 3D view button to instantly generate a PDF document containing all visible objects in your current 3D view.
  • On the 3D PDF component tab, click the Email active 3D view button to instantly generate an email with an attached PDF document containing all visible objects in your current 3D view.
    3d pdf
  • In the Paper View, any 3D View Port can be used to generate dynamic 3D contents for PDF output by checking the box To 3D PDF.
    3d pdf paper view

Note:

If you are working with alternatives, only the 3D objects in your currently active alternative will be included. If you only have one alternative, then all objects in the drawing are included.

To view 3D in your PDF reader, you need a minimum of Adobe Reader 8, or newer.

To the top


 

Collect the Tools You Use the Most

To personalize CET Designer and speed up your workflow, you can now create a custom, free-floating toolbox.

1custom toolbox

To activate and set up, go into edit mode by holding down the left mouse button on a section header. Once in edit mode, simply drag the section you want out of the tab, and a dialog is created.
You can then add more sections to your toolbox by dragging additional sections from any component tab into your toolbox by repeating the procedure.

If you need to re-open your toolbox, just go to the Tools menu and select Open custom tools, or simply pull out a new section, which will then be added to the bottom of your existing setup.

Click here to view a short video showing just how to create your own toolbox.

To the top


 

Pin and Sort Your Component Tabs

Also as a way of further customizing your CET Designer, you can now pin and sort your component tabs. Pinning your favorite tabs places them on the top of the list, which helps you find the ones you use most frequently and reduces the need to scroll up and down the list. You pin or unpin a component tab either by Ctrl + left click, or by clicking the pin icon in the tooltip.

PinComponentTab_5.0_Eng

Pinned tabs can be sorted to the order you want, by grabbing and dragging them up or down in the list.

Click here to view a short video showing just how to pin and sort your component tabs.

To the top


 

Changed Looks and Functionality for Component Tabs

  • Taking a further step towards modernizing the CET Designer user interface, the component tabs have received a facelift.
    old component tabs new component tabs
    Old                 New
  • When scrolling through the contents of a tab, sections are now automatically closed and opened if all the tab contents do not fit on the screen at the same time. Individual tabs also remember their manually changed open/close states.
  • Arrows at the top and bottom let you immediately jump to the top or bottom of a tab, if there are more sections than can currently fit on the screen.
    2up arrow in component tab
  • You can now hide any individual sections of a tab that you do not wish to see. Holding down the left mouse button on a section header will make CET Designer go into edit mode. Clicking the red X will hide the particular section until further notice.
    1section red x
  • Right-clicking on a section, while in edit mode, will bring up additional options for expanding/collapsing sections and hiding/showing hidden tabs. This can also be controlled from within the Component Tabs Configurator (see below).
    rightclicking a section
  • The Component Tabs Configurator has been updated with expanded functionality. You can now configure not only which tabs will be visible, but also which of their sections that will be visible and the order in which they are displayed.
    1component tabs config

 

 

To the top


 

Introducing Work Modes to Replace the User Level Options

Striving for a more customizable interface in CET Designer, we are introducing Work Modes. They are designed to help you focus on the tools that you need for the task at hand. This new system means that we are removing the old User Levels (Standard/Expert) options from the Control Panel.

WorkModes_5.0_Eng

We are starting off with five pre-defined work modes. Four that come with CET Designer and one that comes with the Movie Studio Extension.

  • Design (show all)
    This work mode enables full access to all tools and features, replacing the old Expert and Standard user levels. This is the default mode for new users.
  • Demo (no edit)
    Intended for presentations and demonstrations; you cannot add or change anything in the drawing, only move the camera and render.
  • Easy Design
    Reduces the number of available buttons and menus in the user interface; making the interface look cleaner and easier to browse through.
  • Make movie
    This work mode comes with the Movie Studio Extension. Enabling this work mode will automatically switch to the Movie Studio tab, hiding all others, instantly making CET Designer ready to focus on movie making. Note: only available if the Movie Studio Extension is installed.
  • Specification
    This lets you turn your focus to working with Calculation and Part Tagging, without the risk of accidentally changing the actual layout.

 

To the top


 

New Tool for Placing and Aligning Objects Simultaneously

We have added a new tool to the 2D view toolbar. The Align tool lets you reposition and align objects with other existing components.

1align tool

Click here to view a short video showing how you can work with the Align tool.

Note: Unless the Try to connect box is checked, the objects will not snap together even when they would normally do so.

To the top


 

Updates to the File Menu Appearance and Functionality

The File menu has been given a new look and added functionality to make it more familiar to those accustomed to the more modern style of Microsoft Office.
Particularly notable are the additions of sections for Drawings (and Drawing history) as well as better management of saved Favorites.

file menu

To the top


 

Improved Handling of Backups and Autosaves

Handling of backups and autosaves has seen a slight change in behavior. Automatically generated files are now put in a separate folder in the same directory as the main drawing instead of the previous behavior of putting autosaves in the same directory as the main drawing file.

Ticking the box for Show backups will make these files visible in the File menu, distinguished from normal saves by their green text.

backups

To the top


 

Updated Look for the Control Panel

Keeping with the style of the File menu, the Control Panel has also been given a new look to make it more familiar to those accustomed to the more modern style of Microsoft Office.

control panel

To the top


 

New Options Added for Part Tagging

  • The color control has been moved up next to the tag names, for easier access.
  • A new option has been added to allow selecting all objects belonging to a specific tag.
    1part tagging

To the top


 

New Selection Indicators Available for the 3D View

New selection indicators for 3D are available from the Control Panel. The two new option (Outline and Stripe outline) will draw an outline around your selection in 3D. This outline will show through other objects to help you get an idea of what is selected even if other objects might obscure parts or your selection. The old option to display a frame around the selection in the 3D view is now called Box in the new dropdown menu.

1outline options

outline exampleoutline example 2

Note: Due to issues with hardware limitations, the outline options are not available on computers using Intel HD Graphics.

To the top


 

Level of Detail Option Enabled by Default

Starting from the 5.0 release, all users of the advanced graphics engine will, by default, see the option for Enable higher 3D detail in realtime enabled. The gains from this is twofold:

  • You should see increased performance when viewing 3D, as CET Designer automatically reduces the level of detail for objects that are farther away from the camera.
  • At the same time, the program will increase the level of detail for objects that are closer to the camera, thus making them look better.

To the top


 

64-bit Version of CET Designer now Available

In order to take better advantage of increased amounts of available memory in modern computers, we now launch a 64-bit version of CET Designer.

The main advantage of a 64-bit version lies in working with larger drawings, a situation that puts a high demand for available memory at the forefront. What this means, is that when working on a larger project, the program will not start to slow down due to reaching memory limits.

While a 32-bit program can utilize a maximum of 2GB of system memory, a 64-bit program has a limit slightly below 200 GB (or as much as is available on the computer).

Note: You will need to download a new installer if you wish to run the 64-bit version, as it is not possible to patch a 32-bit installation into 64-bit.

To the top


 

Changes

The Extensions Button has been Renamed

The Extensions button has been renamed to fit with the new Marketplace.

1marketplace button

To the top


 

Better Visibility When Using the Position Tool

Right-clicking when using the Position tool will now show a path to help you see better just how your object is moved and positioned in the drawing area.

PositionToolPath_5.0_Eng

Click here to view a short video that shows how you can use the Position tool.

To the top


 

Added Functionality in the Paper View

The Paper Manager tool now supports the use of SHIFT (in addition to Ctrl) to allow selecting multiple papers at the same time.

To the top


 

Easier Print Management

  • The Print Reports dialog has been extended to include control of which papers to print, as well as controls for paper settings and orientation.
    1print reports
  • The Print Reports dialog now also supports printing in a different language from what CET Designer is set to, the same goes for currency.
    2print reports 2

To the top


 

New Icons in the Lights Extension

The components in the Lights Extension have been updated with new icons.

light icons

To the top


 

The RevLink Extension now Available Offline

The active connection required by RevLink has been removed, and is now replaced by Import/Export features. Export and import functions only work with Revit floor plans – other types of plans like structural plans and ceiling plans are not supported.

While we have added support for the Revit 2015 format, we have also removed support for the discontinued Revit 2010 format.

To the top


 

Performance Improvements in the SketchUp Extension

  • Added support for the new SketchUp 2014 format.
  • Added support for drag and drop import.
  • Polygon reduction is now automatically turned on to help improve performance. Renderings done in Photo Lab will display the higher detail version of models.
  • Textures are not shown in the live view to help improve performance. Renderings done in Photo Lab will display textures.
  • Added support for importing models named using special (non-ASCII) characters.

To the top


 

Solved Issues

Miscellaneous

  • Fixed problem that could sometimes cause Customer Own Materials (COMs) to turn black in the Scheme Manager.
  • Fixed problem with imported CAD files ignoring set elevations.
  • Fixed problem with Locking/Unlocking of View Ports in Paper View that would cause the view to zoom in or out slightly.
  • Fixed problem with using keyboard shortcuts to delete papers in the Paper Manager that could cause the dialog to not correctly update its contents.
  • Fixed problem with starting CET Designer in offline mode that could lead to Catalogue data not getting downloaded.
  • Fixed problem with Print Preview started from Calculation not showing custom company logotypes that had been added.
  • Fixed problem with CAD import dialog not correctly showing which tab was selected.
  • Fixed problem with Blocks and some Steelcase chairs that could cause a system slowdown.
  • Fixed problem that in rare cases could cause the Photo Lab to Contour render snap point as if they were actual objects in the drawing.
  • Fixed problem that could cause incorrect warnings about missing files for Extensions that the user did not have installed.
  • Fixed problem with loaded items missing their required extension, causing them to vanish if F5 was pressed.
  • Fixed several issues with SketchUp that could cause crashes under different circumstances.
  • Fixed issue that could cause a crash when opening the Control Panel.

To the top

Leave a Reply