CET Designer 10.0

Last modified: Jul 15, 2019
More about Release Notes

[Open a printable version]

sweden [Söker du release notes på svenska?]
[Suchen Sie Release Notes auf Deutsch?]
spain [Buscando las Notas de Lanzamiento en español?]
china [您正在寻找中文版的版本说明吗 ?]
japan [日本語版のリリースノートはこちらへ ]

Update – Patch 2 (July 15, 2019)

News & changes

Dimensions

  • Text on Dimensions is now able to be displayed on multiple lines:
    dimension

 

IFC

  • In Import & Export, the Import Floor button has been renamed to Import Single Level:
    ifc
  • Transparency is supported in 3D view so objects like glass windows and curtain walls can be better presented:
    ifc2
  • Filters have been added to the import dialog, adding control over which Floors and what other elements to include during import:ifc3
  • Filters have also been added to the export dialog:
    ifc4
  • CET Designer now supports applying new materials to imported IFC objects.

 

Multiple Levels

  • Duplicate Level information has been removed from Level Overview.

 

Import & Export

  • Added support for the FBX file format (*.fbx).
  • Added support for the STEP file format (*.stp).
    Please note that this requires a license to use which can be obtained from the Marketplace.

 

Solved Issues

  • Fixed problem with rendering that could cause the materials in a drawing to get switched.
  • Fixed problem with Building Mechanicals that could cause the materials to not get applied to
  • Fixed problem with the IFC file export that could cause materials to not export correctly, or to not export at all.
  • Improved performance and quality for IFC files in 2D view and graphical support.
  • Fixed issue that could cause a crash when creating an Elevation View.

 

Update – Patch 1 (June 18, 2019)

News & Changes

Structural Extension

  • It is now possible to apply  materials to the steel beams.
    MaterialOnSteelBeams

Revlink

  • Added support for Revit 2020.

 

Solved Issues

  • Fixed problem with the new splash screen that could cause the status text to look chopped off.
  • Fixed problem with the Realistic preset in Photo Lab that could cause the light sources to turn black when rendered.
  • Fixed problem with Photo Lab that could cause the Undo/Redo functions to not apply for the settings in Simple Mode.
  • Fixed problem with the Movement aid that could cause snapping to not work properly.
  • Fixed problem with Tools that could cause the arrows to not appear in certain View Modes.
  • Fixed problem with the Print output that could cause the page number to be incorrect when a few papers were disabled.
  • Fixed problem with the Elevation View tool that could cause the image created to be incomplete.
  • Fixed problem with Accessories that could cause the models to not be able to be disconnected after snapping.
  • Fixed problem with Revlink that could cause the layout import to fail when Export textures was enabled during export in CET Designer.
  • Improved performance to lock View Ports in Paper View for drawings that contain CAD files and use Filter.
  • Improved the graphical representation for the S-beam profile in the Structural Extension.
  • Fixed issue that could cause a crash when the Elevation View tool was dragged from one location to another.
  • Fixed issue that could cause a crash when rendering a movie from a drawing that had no floor.
  • Fixed issue that could cause a crash when importing a SketchUp file that had zero file size.

 

Main Release, May 20, 2019

News & Changes

Startup & Interface

  • A new Splash Screen has been added, showcasing winners of last year’s CET Designer Awards. The new splash screen will also provide a little more detail about which Extension or part of Extension is currently being started.SplashScreen_100
  • We have redesigned the look of the 2D and 3D toolbars as a step towards modernizing the interface of CET Designer. This update also includes an updated toolbar for the Paper View.
  • A new option, called Follow 2D View has been added to the 3D toolbar. Enabling this feature will make the 3D View pan and zoom follow any panning or zooming done in the 2D View.
    Follow2DViewHighlighted_100
    If you have more than one 2D View active, you can select from a dropdown which view the 3D should follow:Follow2DViewMultipleViews_100
  • The tool for disabling snapping has a new icon and has moved farther to the right in both the 2D and 3D toolbars:
    SnappingDisabled_100
    Snapping enabled (default)
    Snapping disabled

    Just as before, you can temporarily override snapping by pressing the Shift key when placing components.

  • Several improvements have been added to the feature for collapsing Component tabs:
    • A new indicator replaces the old triangle for collapsed tabs, hopefully making it easier to identify a group of collapsed tabs:
      CollapsedGroupBarIndicator_100_eng
    • The previous brackets in the tooltip for collapsing tabs have been replaced by a clearer icon:
      CollapseComponentTabsArrowIcon_100_eng
    • Right-clicking a component tab and swiping up collapses all tabs; right-clicking a component tab and swiping down expands all tabs.
    • To prevent accidentally collapsing tabs, double-clicking has been removed as an option. Though the option still exists in the right-click menu.
  • The two buttons that would previously let you choose between Single select and Multi select have been combined into one button with two different states:
    Multi select active (default);
    click for Single select
    Single select active;
    click for Multi select

    Please note that this button has also changed location and can now be found to the far right on both the 2D and 3D toolbars.

 

IFC Extension

  • If the IFC Extension is active in CET Designer, it automatically adds support for the IFC file format to the File Import dialog.
  • It is now possible to view the data details of imported IFC objects through the Query dialog.

 

Photo Lab

  • A new render preset has been added to the Simple mode of the Photo Lab; the Realistic preset. Think of Product Lighting as a perfect studio setup; cheating to guarantee a good look, with a focus on your products. Objects will look good, benefiting from the preset, even without walls and ceiling. Realistic lighting, on the other hand, replicates actual atmosphere and sunlight (simulating a cloud-free sky) and is intended for generating a realistic look for whole rooms. To fully benefit from this light preset, you will need a full scene with walls, ceiling, floor and other objects with different colors and materials to give the light a chance to bounce off of, as it would in a real room.
  • A tool for controlling the direction of sunlight has been added to all applicable presets in the Simple mode of the Photo Lab. The same tool is also available in Advanced mode, offering a few additional controls.
    SunlightSetting_100
    The Auto button asks CET Designer to automatically place the sun, so it shines in through one or more windows in the drawing. The tool will typically try to find one of the windows closest to the camera for the sun to shine in through.
  • Basic resolution control has been added for all presets in the Simple mode of the Photo Lab, letting you choose between a limited set of the more common image sizes.
    ResolutionInSimpleMode_100
  • The Photo Lab also sees the introduction of a simplified quality control slider for the applicable render presets in Simple mode.RenderQualityInSimpleMode_100
    The farther to the right the slider is pulled, the better the resulting image will look. But it will also take a lot more time to complete the image as it enables more and more features while requesting higher and higher quality.
  • The advanced mode of the Photo Lab has been updated to reflect some of the changes to the simple mode.
    RenderQuality_100_eng
    Render quality now shows as a slider and the controls for HDR, Anti-alias and Denoising have been moved into the detailed settings available if the box for Show settings is checked. We have also chosen to fully expose a lot more of the detailed render settings, which can be accessed by checking the “show settings” box.

 

Miscellaneous

  • Following your feedback, we are changing the Polar Replicate behavior back to the way it was in version 9.0; i.e. you pick the object you wish to replicate, and then pick the point you wish to replicate it around.
  • Recent enhancements in the advanced graphics engine have resulted in improved precision when creating Elevation views. This means that the option in the Control Panel for generating isometric views with the simple engine has now been removed as the simple graphics engine has been completely discontinued.
  • The DWG Export Filter dialog settings have been simplified; the Available choices options of Selection/Category/Tags have been removed, and instead replaced with a Filter tab for easier control.
    Old
    New
  • Added ability to rename Custom created categories; simply double-click the category name to change it.
  • Improved handling of imported dwg files leading to improved performance for locked 2D View Ports in the Paper View.
  • Updated the Import & Export section of the CET Designer File menu to reflect new functionality; Import Cad (dwg/dxf) drawing… has been renamed to Import File…
    ImportExportOption_100_eng
  • The tool Select object from a list of all beneath the cursor has been added to the 3D toolbar and now works in the 3D View just as for the 2D View. While the animation is active, the object that would be selected is now highlighted as you move the pointer around in the view:
    SelectOverlapping1_100
    While the selection list is showing, CET Designer will now also more clearly highlight which object will be selected. This can be especially helpful if you have multiple overlapping objects with the same name.
    SelectOverlapping2_100
    You can also use the keyboard shortcut Ctrl + right-click to select a specific object.

 

Known Issues

  • If the new Realistic Light option in the Photo Lab is enabled, this will cause the light tiles in Fluorescent Ceilings to turn black. Though they will still give off light.
  • Object selection made in the 2D view, while working in split 2D/3D view, will be lost when switching to a 3D only view.

 

Solved Issues

  • Fixed issue with Revision Cloud that could cause a crash when a custom shape Revision Cloud was stretched to an extreme size.
  • Fixed problem with the Filter field in the Print Reports dialog that would cause it to not display any contents if the dialog was opened while in the Paper View.
  • Fixed problem with dimension value rounding with four decimal precision, that could cause the system to incorrectly round the last decimal down instead of up when the following decimal value was 5.
  • Fixed problem with Levels that could result in objects copied to a Level being deleted, if their Level of origin was removed.
  • Fixed problem with copy and paste of imported spreadsheets that would cause them to rescale based on the zoom level in the 2D View when pasted.
  • Fixed problem with Locked objects, that would sometimes let Replicate tools affect them, despite the object being locked.
  • Fixed problem with imported IFC objects, that could cause them to change color when reloading the drawing.
  • Fixed problem with imported IFC objects and the Zero Point, that could cause positioning issues when exporting from CET Designer to IFC.
  • Improved performance when snapping to lines on imported images.
  • Fixed problem with Custom Shapes that could cause unwanted black dots to show up when unmerging two merged shapes.
  • Fixed problem with Custom Shapes that could cause shapes without a thickness to not carry along objects placed on top of them, when moved.
  • Fixed issue with Custom Shapes that could cause a crash when changing elevation through its green property box.
  • Fixed problem with Custom Shapes that could cause holes to not be visible until the view was refreshed.
  • Fixed problem with Accessories, that could cause settings to be accidentally overwritten for existing accessory objects, when changing the same property value on a different accessory object.
  • Fixed problem with drawing export, that would cause filter settings to not work when exporting to .skp / .ifc / .obj
  • Fixed problem with Project Info in data fields that could cause the contents to revert to default.
  • Fixed problem with Project Info export that could cause the information in the files to not import correctly when trying to bring the data back in at a later time.

12 Responses to “CET Designer 10.0”

  1. Thomas Geyer says:

    Hello,

    i’ve tried to install CET 10.0 but after the installation CET tries to install updates but it doesn’t work.

    Background installation failed… :-(

    could you please help me?

    best regards
    Thomas

  2. Thomas Gallagher says:

    Excited for 10.0, thanks for the helpful updates!

  3. Is CET Designer 10 a separate installation from the previous versions? Currently have 9.5 and no new updates are showing.

    • CET Designer 10.0 is not a separate installation. It could be because you have an Extension that is not yet on 10.0, which would then block your update. Please contact CET Support, and they’ll be able to check that for you. They’re available on phone or chat via our Support page: https://www.configura.com/cet/support/

  4. Emily Lievense says:

    A major change for release 10.0 is to have only 1 button for single select and group select – could you add explanation of that to this what’s new document and also about using Control + Right-click to select a specific product.

  5. Shridhara says:

    Thanks for the update

    Can we add Elevations tool into 2D toolbar for the quick access to create front & side views

    • I’d recommend you to submit that as a feature request (from the Help menu in CET Designer). The more people asking for specific features, the greater chance that we might implement it.

  6. Dave Kilian says:

    I updated CET to 10.0 (64 bit) The first think I noticed was now at the right side of my work screen there is a large “watermark” that I cannot get rid of. At that time it was the only issue. Not I have trouble starting the program if my extra monitor is plugged in. It crashes on me immediately. If I get it to start on just my computer, when I go to render my image it will crash if it hasn’t already.

Leave a Reply